installing apex in Windows

  apex, installation, python, windows

I want to install apex on Windows. However, it fails and the following message appears:

Collecting apex
  Using cached apex-0.9.10dev.tar.gz (36 kB)
Collecting cryptacular
  Using cached cryptacular-1.5.5.tar.gz (39 kB)
  Installing build dependencies ... done
  Getting requirements to build wheel ... done
    Preparing wheel metadata ... error
    ERROR: Command errored out with exit status 1:
     command: 'c:usersappdatalocalprogramspythonpython39python.exe' 'c:usersappdatalocalprogramspythonpython39libsite-packagespip_vendorpep517in_process_in_process.py' prepare_metadata_for_build_wheel 'C:UsersAppDataLocalTemptmpdqtwvtby'
         cwd: C:UsersAppDataLocalTemppip-install-ipbr8slhcryptacular_ada3d474ab4e459b9ce2bdb8db71864f
    Complete output (50 lines):
    scons: Reading SConscript files ...

    scons: warning: VC version 14.2 not installed.  C/C++ compilers are most likely not set correctly.
     Installed versions are: []
    File "C:UsersAppDataLocalTemppip-install-ipbr8slhcryptacular_ada3d474ab4e459b9ce2bdb8db71864fSConstruct", line 25, in <module>

    scons: warning: VC version 14.2 not installed.  C/C++ compilers are most likely not set correctly.
     Installed versions are: []
    File "C:UsersAppDataLocalTemppip-install-ipbr8slhcryptacular_ada3d474ab4e459b9ce2bdb8db71864fSConstruct", line 25, in <module>
    DistutilsPlatformError: Unable to find vcvarsall.bat:
      File "C:UsersAppDataLocalTemppip-install-ipbr8slhcryptacular_ada3d474ab4e459b9ce2bdb8db71864fSConstruct", line 25:
        env = Environment(
      File "C:UsersAppDataLocalTemppip-build-env-o7y14ah2overlayLibsite-packagesSConsEnvironment.py", line 1013:
        apply_tools(self, tools, toolpath)
      File "C:UsersAppDataLocalTemppip-build-env-o7y14ah2overlayLibsite-packagesSConsEnvironment.py", line 116:
        env.Tool(tool)
      File "C:UsersAppDataLocalTemppip-build-env-o7y14ah2overlayLibsite-packagesSConsEnvironment.py", line 1871:
        tool(self)
      File "C:UsersAppDataLocalTemppip-build-env-o7y14ah2overlayLibsite-packagesensconscpyext.py", line 108:
        ext = get_build_ext()
      File "C:UsersAppDataLocalTemppip-build-env-o7y14ah2overlayLibsite-packagesensconscpyext.py", line 84:
        cmd.run()
      File "c:usersappdatalocalprogramspythonpython39libdistutilscommandbuild_ext.py", line 340:
        self.build_extensions()
      File "c:usersappdatalocalprogramspythonpython39libdistutilscommandbuild_ext.py", line 449:
        self._build_extensions_serial()
      File "c:usersappdatalocalprogramspythonpython39libdistutilscommandbuild_ext.py", line 474:
        self.build_extension(ext)
      File "C:UsersAppDataLocalTemppip-build-env-o7y14ah2overlayLibsite-packagesensconscpyext.py", line 64:
        build_ext.build_extension(self, ext)
      File "c:usersappdatalocalprogramspythonpython39libdistutilscommandbuild_ext.py", line 529:
        objects = self.compiler.compile(sources,
      File "c:usersappdatalocalprogramspythonpython39libdistutils_msvccompiler.py", line 323:
        self.initialize()
      File "c:usersappdatalocalprogramspythonpython39libdistutils_msvccompiler.py", line 220:
        vc_env = _get_vc_env(plat_spec)
      File "c:usersappdatalocalprogramspythonpython39libdistutils_msvccompiler.py", line 122:
        raise DistutilsPlatformError("Unable to find vcvarsall.bat")
    Traceback (most recent call last):
      File "c:usersappdatalocalprogramspythonpython39libsite-packagespip_vendorpep517in_process_in_process.py", line 280, in <module>
        main()
      File "c:usersappdatalocalprogramspythonpython39libsite-packagespip_vendorpep517in_process_in_process.py", line 263, in main
        json_out['return_val'] = hook(**hook_input['kwargs'])
      File "c:usersappdatalocalprogramspythonpython39libsite-packagespip_vendorpep517in_process_in_process.py", line 133, in prepare_metadata_for_build_wheel
        return hook(metadata_directory, config_settings)
      File "C:UsersAppDataLocalTemppip-build-env-o7y14ah2overlayLibsite-packagesensconsapi.py", line 35, in prepare_metadata_for_build_wheel
        return _run("dist_info")
      File "C:UsersAppDataLocalTemppip-build-env-o7y14ah2overlayLibsite-packagesensconsapi.py", line 29, in _run
        lookup = SCons.Node.arg2nodes_lookups[0](alias).sources[0]
    AttributeError: 'NoneType' object has no attribute 'sources'
    ----------------------------------------
WARNING: Discarding https://files.pythonhosted.org/packages/ec/d6/a82d191ec058314b2b7cbee5635150f754ba1c6ffc05387bc9a57efe48b8/cryptacular-1.5.5.tar.gz#sha256=fb4d48716e88e4d050255ff0f065f6d437caa358ceef16ba5840c95cece224f9 (from https://pypi.org/simple/cryptacular/). Command errored out with exit status 1: 'c:usersappdatalocalprogramspythonpython39python.exe' 'c:usersappdatalocalprogramspythonpython39libsite-packagespip_vendorpep517in_process_in_process.py' prepare_metadata_for_build_wheel 'C:UsersAppDataLocalTemptmpdqtwvtby' Check the logs for full command output.
  Using cached cryptacular-1.5.1.tar.gz (39 kB)
  Installing build dependencies ... done
  Getting requirements to build wheel ... done
    Preparing wheel metadata ... error
    ERROR: Command errored out with exit status 1:
     command: 'c:usersappdatalocalprogramspythonpython39python.exe' 'c:usersappdatalocalprogramspythonpython39libsite-packagespip_vendorpep517in_process_in_process.py' prepare_metadata_for_build_wheel 'C:UsersAppDataLocalTemptmpvsrq5fqq'
         cwd: C:UsersAppDataLocalTemppip-install-ipbr8slhcryptacular_85e13ce853874f05a67d852b03fc0866
    Complete output (50 lines):
    scons: Reading SConscript files ...

    scons: warning: VC version 14.2 not installed.  C/C++ compilers are most likely not set correctly.
     Installed versions are: []
    File "C:UsersAppDataLocalTemppip-install-ipbr8slhcryptacular_85e13ce853874f05a67d852b03fc0866SConstruct", line 25, in <module>

    scons: warning: VC version 14.2 not installed.  C/C++ compilers are most likely not set correctly.
     Installed versions are: []
    File "C:UsersAppDataLocalTemppip-install-ipbr8slhcryptacular_85e13ce853874f05a67d852b03fc0866SConstruct", line 25, in <module>
    DistutilsPlatformError: Unable to find vcvarsall.bat:
      File "C:UsersAppDataLocalTemppip-install-ipbr8slhcryptacular_85e13ce853874f05a67d852b03fc0866SConstruct", line 25:
        env = Environment(
      File "C:UsersAppDataLocalTemppip-build-env-hblsgl2moverlayLibsite-packagesSConsEnvironment.py", line 1013:
        apply_tools(self, tools, toolpath)
      File "C:UsersAppDataLocalTemppip-build-env-hblsgl2moverlayLibsite-packagesSConsEnvironment.py", line 116:
        env.Tool(tool)
      File "C:UsersAppDataLocalTemppip-build-env-hblsgl2moverlayLibsite-packagesSConsEnvironment.py", line 1871:
        tool(self)
      File "C:UsersAppDataLocalTemppip-build-env-hblsgl2moverlayLibsite-packagesensconscpyext.py", line 108:
        ext = get_build_ext()
      File "C:UsersAppDataLocalTemppip-build-env-hblsgl2moverlayLibsite-packagesensconscpyext.py", line 84:
        cmd.run()
      File "c:usersappdatalocalprogramspythonpython39libdistutilscommandbuild_ext.py", line 340:
        self.build_extensions()
      File "c:usersappdatalocalprogramspythonpython39libdistutilscommandbuild_ext.py", line 449:
        self._build_extensions_serial()
      File "c:usersappdatalocalprogramspythonpython39libdistutilscommandbuild_ext.py", line 474:
        self.build_extension(ext)
      File "C:UsersAppDataLocalTemppip-build-env-hblsgl2moverlayLibsite-packagesensconscpyext.py", line 64:
        build_ext.build_extension(self, ext)
      File "c:usersappdatalocalprogramspythonpython39libdistutilscommandbuild_ext.py", line 529:
        objects = self.compiler.compile(sources,
      File "c:usersappdatalocalprogramspythonpython39libdistutils_msvccompiler.py", line 323:
        self.initialize()
      File "c:usersappdatalocalprogramspythonpython39libdistutils_msvccompiler.py", line 220:
        vc_env = _get_vc_env(plat_spec)
      File "c:usersappdatalocalprogramspythonpython39libdistutils_msvccompiler.py", line 122:
        raise DistutilsPlatformError("Unable to find vcvarsall.bat")
    Traceback (most recent call last):
      File "c:usersappdatalocalprogramspythonpython39libsite-packagespip_vendorpep517in_process_in_process.py", line 280, in <module>
        main()
      File "c:usersappdatalocalprogramspythonpython39libsite-packagespip_vendorpep517in_process_in_process.py", line 263, in main
        json_out['return_val'] = hook(**hook_input['kwargs'])
      File "c:usersappdatalocalprogramspythonpython39libsite-packagespip_vendorpep517in_process_in_process.py", line 133, in prepare_metadata_for_build_wheel
        return hook(metadata_directory, config_settings)
      File "C:UsersAppDataLocalTemppip-build-env-hblsgl2moverlayLibsite-packagesensconsapi.py", line 35, in prepare_metadata_for_build_wheel
        return _run("dist_info")
      File "C:UsersAppDataLocalTemppip-build-env-hblsgl2moverlayLibsite-packagesensconsapi.py", line 29, in _run
        lookup = SCons.Node.arg2nodes_lookups[0](alias).sources[0]
    AttributeError: 'NoneType' object has no attribute 'sources'
    ----------------------------------------
WARNING: Discarding https://files.pythonhosted.org/packages/09/19/6f3276ee6013db5f3e091b733de21b7ac7f9af0465732f07cf0f03dac300/cryptacular-1.5.1.tar.gz#sha256=f5d3d0917ad24705bcb7cf9e91cafaf49705718bc41f2794f471f136f50e8219 (from https://pypi.org/simple/cryptacular/). Command errored out with exit status 1: 'c:usersappdatalocalprogramspythonpython39python.exe' 'c:usersappdatalocalprogramspythonpython39libsite-packagespip_vendorpep517in_process_in_process.py' prepare_metadata_for_build_wheel 'C:UsersAppDataLocalTemptmpvsrq5fqq' Check the logs for full command output.
  Using cached cryptacular-1.5.0.tar.gz (39 kB)
  Installing build dependencies ... done
  Getting requirements to build wheel ... done
    Preparing wheel metadata ... error
    ERROR: Command errored out with exit status 1:
     command: 'c:usersappdatalocalprogramspythonpython39python.exe' 'c:usersappdatalocalprogramspythonpython39libsite-packagespip_vendorpep517in_process_in_process.py' prepare_metadata_for_build_wheel 'C:UsersAppDataLocalTemptmp2suixd7n'
         cwd: C:UsersAppDataLocalTemppip-install-ipbr8slhcryptacular_ccbe4935c0e848eebc3dc1d111d00f06
    Complete output (50 lines):
    scons: Reading SConscript files ...

    scons: warning: VC version 14.2 not installed.  C/C++ compilers are most likely not set correctly.
     Installed versions are: []
    File "C:UsersAppDataLocalTemppip-install-ipbr8slhcryptacular_ccbe4935c0e848eebc3dc1d111d00f06SConstruct", line 25, in <module>

    scons: warning: VC version 14.2 not installed.  C/C++ compilers are most likely not set correctly.
     Installed versions are: []
    File "C:UsersAppDataLocalTemppip-install-ipbr8slhcryptacular_ccbe4935c0e848eebc3dc1d111d00f06SConstruct", line 25, in <module>
    DistutilsPlatformError: Unable to find vcvarsall.bat:
      File "C:UsersAppDataLocalTemppip-install-ipbr8slhcryptacular_ccbe4935c0e848eebc3dc1d111d00f06SConstruct", line 25:
        env = Environment(
      File "C:UsersAppDataLocalTemppip-build-env-_u9jstmnoverlayLibsite-packagesSConsEnvironment.py", line 1013:
        apply_tools(self, tools, toolpath)
      File "C:UsersAppDataLocalTemppip-build-env-_u9jstmnoverlayLibsite-packagesSConsEnvironment.py", line 116:
        env.Tool(tool)
      File "C:UsersAppDataLocalTemppip-build-env-_u9jstmnoverlayLibsite-packagesSConsEnvironment.py", line 1871:
        tool(self)
      File "C:UsersAppDataLocalTemppip-build-env-_u9jstmnoverlayLibsite-packagesensconscpyext.py", line 108:
        ext = get_build_ext()
      File "C:UsersAppDataLocalTemppip-build-env-_u9jstmnoverlayLibsite-packagesensconscpyext.py", line 84:
        cmd.run()
      File "c:usersappdatalocalprogramspythonpython39libdistutilscommandbuild_ext.py", line 340:
        self.build_extensions()
      File "c:usersappdatalocalprogramspythonpython39libdistutilscommandbuild_ext.py", line 449:
        self._build_extensions_serial()
      File "c:usersappdatalocalprogramspythonpython39libdistutilscommandbuild_ext.py", line 474:
        self.build_extension(ext)
      File "C:UsersAppDataLocalTemppip-build-env-_u9jstmnoverlayLibsite-packagesensconscpyext.py", line 64:
        build_ext.build_extension(self, ext)
      File "c:usersappdatalocalprogramspythonpython39libdistutilscommandbuild_ext.py", line 529:
        objects = self.compiler.compile(sources,
      File "c:usersappdatalocalprogramspythonpython39libdistutils_msvccompiler.py", line 323:
        self.initialize()
      File "c:usersappdatalocalprogramspythonpython39libdistutils_msvccompiler.py", line 220:
        vc_env = _get_vc_env(plat_spec)
      File "c:usersappdatalocalprogramspythonpython39libdistutils_msvccompiler.py", line 122:
        raise DistutilsPlatformError("Unable to find vcvarsall.bat")
    Traceback (most recent call last):
      File "c:usersappdatalocalprogramspythonpython39libsite-packagespip_vendorpep517in_process_in_process.py", line 280, in <module>
        main()
      File "c:usersappdatalocalprogramspythonpython39libsite-packagespip_vendorpep517in_process_in_process.py", line 263, in main
        json_out['return_val'] = hook(**hook_input['kwargs'])
      File "c:usersappdatalocalprogramspythonpython39libsite-packagespip_vendorpep517in_process_in_process.py", line 133, in prepare_metadata_for_build_wheel
        return hook(metadata_directory, config_settings)
      File "C:UsersAppDataLocalTemppip-build-env-_u9jstmnoverlayLibsite-packagesensconsapi.py", line 35, in prepare_metadata_for_build_wheel
        return _run("dist_info")
      File "C:UsersAppDataLocalTemppip-build-env-_u9jstmnoverlayLibsite-packagesensconsapi.py", line 29, in _run
        lookup = SCons.Node.arg2nodes_lookups[0](alias).sources[0]
    AttributeError: 'NoneType' object has no attribute 'sources'
    ----------------------------------------
WARNING: Discarding https://files.pythonhosted.org/packages/dc/96/0b7b9ceb01c7754f602d26ef6703e89b48275970c50e773dda68d38581b1/cryptacular-1.5.0.tar.gz#sha256=a154c672a833d40ccad6820f7307be5816db66fd3544507b99c3d91a8c59fde8 (from https://pypi.org/simple/cryptacular/). Command errored out with exit status 1: 'c:usersappdatalocalprogramspythonpython39python.exe' 'c:usersappdatalocalprogramspythonpython39libsite-packagespip_vendorpep517in_process_in_process.py' prepare_metadata_for_build_wheel 'C:UsersAppDataLocalTemptmp2suixd7n' Check the logs for full command output.
  Using cached cryptacular-1.4.1.tar.gz (40 kB)
Requirement already satisfied: zope.sqlalchemy in c:usersappdatalocalprogramspythonpython39libsite-packages (from apex) (1.4)
Requirement already satisfied: velruse>=1.0.3 in c:usersappdatalocalprogramspythonpython39libsite-packages (from apex) (1.1.1)
Requirement already satisfied: pyramid>1.1.2 in c:usersappdatalocalprogramspythonpython39libsite-packages (from apex) (2.0)
Requirement already satisfied: pyramid_mailer in c:usersappdatalocalprogramspythonpython39libsite-packages (from apex) (0.15.1)
Requirement already satisfied: requests in c:usersappdatalocalprogramspythonpython39libsite-packages (from apex) (2.25.1)
Requirement already satisfied: wtforms in c:usersappdatalocalprogramspythonpython39libsite-packages (from apex) (2.3.3)
Requirement already satisfied: wtforms-recaptcha in c:usersappdatalocalprogramspythonpython39libsite-packages (from apex) (0.3.2)
Requirement already satisfied: hupper>=1.5 in c:usersappdatalocalprogramspythonpython39libsite-packages (from pyramid>1.1.2->apex) (1.10.3)
Requirement already satisfied: plaster-pastedeploy in c:usersappdatalocalprogramspythonpython39libsite-packages (from pyramid>1.1.2->apex) (0.7)
Requirement already satisfied: webob>=1.8.3 in c:usersappdatalocalprogramspythonpython39libsite-packages (from pyramid>1.1.2->apex) (1.8.7)
Requirement already satisfied: zope.deprecation>=3.5.0 in c:usersappdatalocalprogramspythonpython39libsite-packages (from pyramid>1.1.2->apex) (4.4.0)
Requirement already satisfied: translationstring>=0.4 in c:usersappdatalocalprogramspythonpython39libsite-packages (from pyramid>1.1.2->apex) (1.4)
Requirement already satisfied: zope.interface>=3.8.0 in c:usersappdatalocalprogramspythonpython39libsite-packages (from pyramid>1.1.2->apex) (5.4.0)
Requirement already satisfied: setuptools in c:usersappdatalocalprogramspythonpython39libsite-packages (from pyramid>1.1.2->apex) (49.2.1)
Requirement already satisfied: venusian>=1.0 in c:usersappdatalocalprogramspythonpython39libsite-packages (from pyramid>1.1.2->apex) (3.0.0)
Requirement already satisfied: plaster in c:usersappdatalocalprogramspythonpython39libsite-packages (from pyramid>1.1.2->apex) (1.0)
Requirement already satisfied: requests-oauthlib in c:usersappdatalocalprogramspythonpython39libsite-packages (from velruse>=1.0.3->apex) (1.3.0)
Requirement already satisfied: anykeystore in c:usersappdatalocalprogramspythonpython39libsite-packages (from velruse>=1.0.3->apex) (0.2)
Requirement already satisfied: python3-openid in c:usersappdatalocalprogramspythonpython39libsite-packages (from velruse>=1.0.3->apex) (3.2.0)
Requirement already satisfied: pbkdf2 in c:usersappdatalocalprogramspythonpython39libsite-packages (from cryptacular->apex) (1.3)
Requirement already satisfied: PasteDeploy>=2.0 in c:usersappdatalocalprogramspythonpython39libsite-packages (from plaster-pastedeploy->pyramid>1.1.2->apex) (2.1.1)
Requirement already satisfied: transaction in c:usersappdatalocalprogramspythonpython39libsite-packages (from pyramid_mailer->apex) (3.0.1)
Requirement already satisfied: repoze.sendmail>=4.1 in c:usersappdatalocalprogramspythonpython39libsite-packages (from pyramid_mailer->apex) (4.4.1)
Requirement already satisfied: defusedxml in c:usersappdatalocalprogramspythonpython39libsite-packages (from python3-openid->velruse>=1.0.3->apex) (0.7.1)
Requirement already satisfied: certifi>=2017.4.17 in c:usersappdatalocalprogramspythonpython39libsite-packages (from requests->apex) (2021.5.30)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in c:usersappdatalocalprogramspythonpython39libsite-packages (from requests->apex) (1.26.6)
Requirement already satisfied: idna<3,>=2.5 in c:usersappdatalocalprogramspythonpython39libsite-packages (from requests->apex) (2.10)
Requirement already satisfied: chardet<5,>=3.0.2 in c:usersappdatalocalprogramspythonpython39libsite-packages (from requests->apex) (4.0.0)
Requirement already satisfied: oauthlib>=3.0.0 in c:usersappdatalocalprogramspythonpython39libsite-packages (from requests-oauthlib->velruse>=1.0.3->apex) (3.1.1)
Requirement already satisfied: MarkupSafe in c:usersappdatalocalprogramspythonpython39libsite-packages (from wtforms->apex) (2.0.1)
Requirement already satisfied: SQLAlchemy!=1.4.0,!=1.4.1,!=1.4.2,!=1.4.3,!=1.4.4,!=1.4.5,!=1.4.6,>=0.9 in c:usersappdatalocalprogramspythonpython39libsite-packages (from zope.sqlalchemy->apex) (1.4.20)
Requirement already satisfied: greenlet!=0.4.17 in c:usersappdatalocalprogramspythonpython39libsite-packages (from SQLAlchemy!=1.4.0,!=1.4.1,!=1.4.2,!=1.4.3,!=1.4.4,!=1.4.5,!=1.4.6,>=0.9->zope.sqlalchemy->apex) (1.1.0)
Using legacy 'setup.py install' for apex, since package 'wheel' is not installed.
Using legacy 'setup.py install' for cryptacular, since package 'wheel' is not installed.
Installing collected packages: cryptacular, apex
    Running setup.py install for cryptacular ... error
    ERROR: Command errored out with exit status 1:
     command: 'c:usersappdatalocalprogramspythonpython39python.exe' -u -c 'import io, os, sys, setuptools, tokenize; sys.argv[0] = '"'"'C:UsersAppDataLocalTemppip-install-ipbr8slhcryptacular_0d811b25006c476d8433f0eb9be51325setup.py'"'"'; __file__='"'"'C:UsersAppDataLocalTemppip-install-ipbr8slhcryptacular_0d811b25006c476d8433f0eb9be51325setup.py'"'"';f = getattr(tokenize, '"'"'open'"'"', open)(__file__) if os.path.exists(__file__) else io.StringIO('"'"'from setuptools import setup; setup()'"'"');code = f.read().replace('"'"'rn'"'"', '"'"'n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record 'C:UsersAppDataLocalTemppip-record-w5pfqvziinstall-record.txt' --single-version-externally-managed --compile --install-headers 'c:usersappdatalocalprogramspythonpython39Includecryptacular'
         cwd: C:UsersAppDataLocalTemppip-install-ipbr8slhcryptacular_0d811b25006c476d8433f0eb9be51325
    Complete output (32 lines):
    running install
    running build
    running build_py
    creating build
    creating buildlib.win-amd64-3.9
    creating buildlib.win-amd64-3.9cryptacular
    copying cryptacular__init__.py -> buildlib.win-amd64-3.9cryptacular
    creating buildlib.win-amd64-3.9cryptacularbcrypt
    copying cryptacularbcrypttest_bcrypt.py -> buildlib.win-amd64-3.9cryptacularbcrypt
    copying cryptacularbcrypt__init__.py -> buildlib.win-amd64-3.9cryptacularbcrypt
    creating buildlib.win-amd64-3.9cryptacularcore
    copying cryptacularcoretest_core.py -> buildlib.win-amd64-3.9cryptacularcore
    copying cryptacularcore__init__.py -> buildlib.win-amd64-3.9cryptacularcore
    creating buildlib.win-amd64-3.9cryptacularcrypt
    copying cryptacularcrypttest_crypt.py -> buildlib.win-amd64-3.9cryptacularcrypt
    copying cryptacularcrypt__init__.py -> buildlib.win-amd64-3.9cryptacularcrypt
    creating buildlib.win-amd64-3.9cryptacularpbkdf2
    copying cryptacularpbkdf2test_pbkdf2.py -> buildlib.win-amd64-3.9cryptacularpbkdf2
    copying cryptacularpbkdf2__init__.py -> buildlib.win-amd64-3.9cryptacularpbkdf2
    running egg_info
    writing cryptacular.egg-infoPKG-INFO
    writing dependency_links to cryptacular.egg-infodependency_links.txt
    writing namespace_packages to cryptacular.egg-infonamespace_packages.txt
    writing requirements to cryptacular.egg-inforequires.txt
    writing top-level names to cryptacular.egg-infotop_level.txt
    reading manifest file 'cryptacular.egg-infoSOURCES.txt'
    reading manifest template 'MANIFEST.in'
    writing manifest file 'cryptacular.egg-infoSOURCES.txt'
    copying cryptacularbcrypt_bcrypt.c -> buildlib.win-amd64-3.9cryptacularbcrypt
    running build_ext
    building 'cryptacular.bcrypt._bcrypt' extension
    error: Microsoft Visual C++ 14.0 is required. Get it with "Build Tools for Visual Studio": https://visualstudio.microsoft.com/downloads/
    ----------------------------------------
ERROR: Command errored out with exit status 1: 'c:usersappdatalocalprogramspythonpython39python.exe' -u -c 'import io, os, sys, setuptools, tokenize; sys.argv[0] = '"'"'C:UsersAppDataLocalTemppip-install-ipbr8slhcryptacular_0d811b25006c476d8433f0eb9be51325setup.py'"'"'; __file__='"'"'C:UsersAppDataLocalTemppip-install-ipbr8slhcryptacular_0d811b25006c476d8433f0eb9be51325setup.py'"'"';f = getattr(tokenize, '"'"'open'"'"', open)(__file__) if os.path.exists(__file__) else io.StringIO('"'"'from setuptools import setup; setup()'"'"');code = f.read().replace('"'"'rn'"'"', '"'"'n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record 'C:UsersAppDataLocalTemppip-record-w5pfqvziinstall-record.txt' --single-version-externally-managed --compile --install-headers 'c:usersappdatalocalprogramspythonpython39Includecryptacular' Check the logs for full command output.

How can I fix this problem and install this package? I have both tried to install it in command prompt using "pip" and from the settings in Pycharm but neither of them was successful. I have also tried the following but it wasn’t successful either.

pip install -v --no-cache-dir --global-option="--cpp_ext" --global-option="--cuda_ext" .

Source: Windows Questions

LEAVE A COMMENT