Setup Flutter behind proxy (407 Proxy Authentication Required)

  flutter, http, proxy, windows

I can’t setup Flutter from behind corporate proxy. When I run flutter doctor I get 407 Proxy Authentication Required. I have correctly setuped http_proxy, https_proxy and no_proxy. I get no problems with any other CLI apps.

$ flutter doctor
Building flutter tool...
Running pub upgrade...
Proxy failed to establish tunnel (407 Proxy Authentication Required)
Error (69): Unable to 'pub upgrade' flutter tool. Retrying in five seconds... (9 tries left)

Am using Windows.

Source: Windows Questions

LEAVE A COMMENT