Error applying provisioning package for multi-app kiosk

I am setting up a multi-app kiosk in audit mode on a fresh install of Win 10 IoT Ent LTSC 1809.

I’ve create an XML assigned access file based on: https://docs.microsoft.com/en-us/windows/configuration/lock-down-windows-10-to-specific-apps

<?xml version="1.0" encoding="utf-8" ?>
<AssignedAccessConfiguration
    xmlns="https://schemas.microsoft.com/AssignedAccess/2017/config"
    xmlns:rs5="https://schemas.microsoft.com/AssignedAccess/201810/config"
    >
    <Profiles>
        <Profile Id="{75C4578C-D56D-402A-A946-CA3CCA60633A}">
            <AllAppsList>
               <AllowedApps>
                    <App DesktopAppPath="C:Windowssystem32mspaint.exe"/>
                    <App DesktopAppPath="C:WindowsSystem32notepad.exe"/>
              </AllowedApps>
            </AllAppsList>
            <StartLayout>
              <![CDATA[<LayoutModificationTemplate xmlns:defaultlayout="https://schemas.microsoft.com/Start/2014/FullDefaultLayout" xmlns:start="https://schemas.microsoft.com/Start/2014/StartLayout" Version="1" xmlns="httsp://schemas.microsoft.com/Start/2014/LayoutModification">
                      <LayoutOptions StartTileGroupCellWidth="4" />
                      <DefaultLayoutOverride>
                        <StartLayoutCollection>
                          <defaultlayout:StartLayout GroupCellWidth="4">
                            <start:Group Name="Group1">
                              <start:DesktopApplicationTile Size="2x2" Column="0" Row="0" DesktopApplicationLinkPath="%ALLUSERSPROFILE%MicrosoftWindowsStart MenuProgramsAccessoriesPaint.lnk" />
                              <start:DesktopApplicationTile Size="2x2" Column="2" Row="0" DesktopApplicationLinkPath="%APPDATA%MicrosoftWindowsStart MenuProgramsAccessoriesNotepad.lnk" />
                            </start:Group>
                          </defaultlayout:StartLayout>
                        </StartLayoutCollection>
                      </DefaultLayoutOverride>
                    </LayoutModificationTemplate>
                ]]>
        </StartLayout>
        <Taskbar ShowTaskbar="true"/>
        </Profile>
    </Profiles>
    <Configs>
        <Config>
            <AutoLogonAccount rs5:DisplayName="Hello World"/>
            <DefaultProfile Id="{75C4578C-D56D-402A-A946-CA3CCA60633A}"/>
        </Config>
    </Configs>
</AssignedAccessConfiguration>

I’ve then used ICD to create a provisioning package using this XML file. When I try applying the package, I get an error and the following event log:

ProvXML category ‘UxLockdown’ failed with ‘0xC00CE223’ at CSP node
‘AssignedAccess/Configuration’. Provisioning failed

From researching this error online, there may be an error in my XML file. I’ve gone over it a few times and validated against the schema but still getting this error.

Can anyone provide help?

Source: Windows Questions

LEAVE A COMMENT