configure: error: Fortran compiler cannot create executables

  android-espresso, c++, fortran, gcc

I’m trying to install Quantum ESPRESSO on my computer and have run into an issue when using the ./configure command in the unpacked directory.

I just updated to macOS Monterey and have GNU Fortran (Homebrew GCC 11.2.0_3) 11.2.0 installed.

When trying to debug this, I looked at the config.log file and looked at similar googled questions. They all point me to updating or reinstalling things, like gcc, which I subsequently did.

Does the problem have to do with this:

(base) [email protected] q-e-qe-6.8 % gcc --version
Configured with: --prefix=/Library/Developer/CommandLineTools/usr --with-gxx-include-dir=/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/include/c++/4.2.1
Apple clang version 11.0.0 (clang-1100.0.33.12)
Target: x86_64-apple-darwin21.2.0
Thread model: posix
InstalledDir: /Library/Developer/CommandLineTools/usr/bin

I can see that the version is 4.2.1, but I’m unaware of what the Apple clang version is. Is it a PATH issue?

I’d appreciate any help.

P.S. Please choose to be kind in responses.

Source: Windows Questions C++

LEAVE A COMMENT