Category : react-native

I am building a ReactNative App for Windows, which worked well until I tried to install AsyncStorage. I already tried reinstalling it, deleting node_modules etc. but I keep getting the following Errors. Any help would be appreciated since I am stuck there. Package Versions are: "@react-native-async-storage/async-storage": "^1.15.15", "react": "17.0.2", "react-native": "0.66.4", "react-native-windows": "0.66.6" Error Messages ..

Read more

So I’m trying to debug why my React Native app won’t run on an Android simulator it told me to run npx react-native run-android with –stacktrace, but when I do I get >>>npx react-native run-android –stacktrace error: unknown option `–stacktrace’ I’ve looked into it and found a couple StackOverflow posts: React Native cannot run stacktrace ..

Read more

I’m new with React Native. I want to build a calling application for windows, android and iOS using SIP(VoIP) method. I took a look at: https://www.doubango.org/sipml5/ and https://github.com/datso/react-native-pjsip But the documentation is not clearly and those 2 libraries is not update for 2-3 years. Anyone here have an idea? Please suggest me. Source: Windows..

Read more

right now I’m trying to integrate a native SDK inside the android folder in a React Native app, but one of the dependencies(implementation "eu.polestar:naosdk:4.9.0") does not work pretty fine. When I try to start the SDK (MediNav) I get one error around the previously mentioned dependencies. java.lang.UnsatisfiedLinkError: No implementation found for java.lang.String com.polestar.naosdk.api.INAOServiceManager.getSoftwareVersion() (tried Java_com_polestar_naosdk_api_INAOServiceManager_getSoftwareVersion ..

Read more